登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

飞哥的技术博客

世上无难事,只怕有心人!

 
 
 

日志

 
 
 
 

RouterOS3.0动态域名DDNS脚本以及其流量控制脚本与RouterOS2.9区别  

2009-06-08 23:07:21|  分类: Linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

 

Routeros v3.0动态域名DDNS脚本
2009-03-08 23:59

以下脚本在routeros 3.7版本上测试通过

============================================================

:global ddnsuser "你的用户名"
:global ddnspass "密码"
:global ddnshost "动态DDNS域名"
:global ddnsip
:global ddnsipfn
:global ddnslastip [:tostr [:resolve $ddnshost] ]
:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
:global ddnsinterface "pppoe-out1你routeros上的拨号名"
:global ddnssystem ("mt-" . [/system package get system version] )

:local int

:local ddnsipfn [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
:global ddnsip [:pick $ddnsipfn 0 [:find $ddnsipfn "/">

:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={

:if ($ddnsip != $ddnslastip) do={

:log info "DDNS: Sending UPDATE!"
:log info [ :put [/tool dns-update address=$ddnsip key-name=$ddnsuser key=$ddnspass ] ]
:global ddnslastip $ddnsip

} else={
:log info "DDNS: No update required."
}

}

RouterOS3.0与2.9流量控制脚本区别
2009-03-08 23:58

RouterOS3.0与2.9流量控制脚本区别
2008-09-22 19:36
由于3.0的脚本命令有所修改,所以RouterOS3.0与2.9流量控制脚本区别

下面是2.9 /queue simple流量控制脚本,即添加从192.168.1.1-192.168.1.100的IP地址流量控制上行256K,下行756K。

:for e from 1 to 100 do={
/queue simple add target-addresses=(192.168.1..$e) max-limit=256000/756000
}

下面则是3.0同样的脚本,在3.0中增加了对字符的定义,即需要对字符串加双引号:

:for e from=1 to=250 do={
/queue simple add target-addresses=("192.168.1." . $e) max-limit=256000/756000
   
}

  评论这张
 
阅读(698)| 评论(0)

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018